Don't trust your UPS

I bought my old UPS, an MGE Pulsar Ellipse 800, about 6 years ago. The expected life time of the batteries is 3–5 years according to the manufacturer. So, I guess I should have been a bit more cautious. However, it has always worked, i.e. it has kept the server and network equipment alive when needed. Furthermore, it does have status LEDs which should flash when the batteries need to be replaced but they never did.

Recently, after an afternoon nap, I found the server out of power and the UPS was signaling "some" trouble. I switched the server back on, without problems, but it was clear that it did not shut down properly as it should have if the UPS provided enough backup power. Once I was back on-line I saw that apparently there wasn't even a power outage, there was probably "only" a surge causing the UPS to switch to battery mode for a few seconds.

Some days after this incident, I decided to do a basic test of the UPS: I shut down the server (i.e. everything that might crash in case of a power outage) and switched it back on but I stopped the boot after the boot menu appeared. Then I pulled the main power plug which supports the UPS causing it to run on batteries. And indeed, all devices got killed immediately. While still running on batteries, I was able to switch the UPS back on. It provided enough power for the network equipment but the server could not be switched on. High time for a replacement!

So, I will add another recurring reminder to my calender: "Manually test the UPS" ;-)

My idea of a basic manual UPS test

  1. Shutdown all connected computers and switch them back on but make sure they do not boot. All other external equipment (network switches, routers, USB stuff etc.) should be switched on, too.
  2. Then pull the mains plug and let the UPS run on batteries for 3-5 minutes. (How long one wants to wait, actually, depends on the capacity of the UPS. Generally, the manuals recommend to not discharge the batteries as this will decrease their capacity.)
  3. If all is fine switch off the UPS (of course, this kills the power of all connected devices) and switch it back on. Your servers should start automatically (unless they are configured otherwise).
  4. Plug in the UPS again! (For the sake of safety you'd rather be quick.)
  5. Check the UPS battery charge level. Ideally, it should be somewhere between 60–99%, again depending on your UPS' capacity.